Installed succesfully, but can't do much else

invibious's Avatar

invibious

23 Oct, 2015 09:25 AM

Hello everyone,

I found this project some days ago and I wanted to give it a try, since it looks very promising. So in advance, thanks for your work.

After downloading the web installer and installing the platform I had access to my admin page. I have added events, releases and such. However, I can't access the main site, it's just the admin page. So there is no place in my server that will give me the main webiste(like http://cashmusic.org) for users to log in and register. Am I doing something wrong? Am I understanding this whole project wrong?

Sorry if this is a question in the category 'noob'. I have never worked with projects over GitHub.

Thanks again for your work.

Take Care,
Ali

  1. 1 Posted by invibious on 23 Oct, 2015 09:28 AM

    invibious's Avatar

    Here are two screenshots when accessing the folder.

  2. 2 Posted by invibious on 23 Oct, 2015 03:10 PM

    invibious's Avatar

    Sorry for three messages in a row; I thought I needed to explain the situation more.

    I have installed Cash Music on XAMPP. I have created a folder named 'install' with the web installer in it, in my root XAMPP folder(which is htdocs). The installation is succesful and I have access to my admin page. However, If I browse to the root folder or install folder it leads me to my admin page or a white screen. I think that the framework needs to be loaded for the site to show up, right?

    So I have created a index.php file in my root folder(so my root folder contains the install folder and the index.php file) with the following code(got the path from the admin page):
    <?php include('C:\xampp\cashmusic\framework\cashmusic.php'); // Initialize CASH Music ?>

    However, this will still leave me with a blank page. So the only page I can access is the admin page, and not the main site.

    I hope I made this more clear now.

  3. 3 Posted by invibious on 23 Oct, 2015 07:31 PM

    invibious's Avatar

    Okay I managed to get the main website to show up by moving all the contents from the 'interface' folder to my htdocs folder, I had to delete the .htaccess file, or I would get a 500 error.

    But the login and sign-up pages are not working now. It can't find the AdminCore, while I have changed the path in the Controller.php.

  4. 4 Posted by invibious on 24 Oct, 2015 09:50 AM

    invibious's Avatar

    Okay another update. I can show the main page and the admin page as well. However, everytime I register for an account I get to the account screen, but every button leads me back to the register page. See the attached screenshot.

    I had to edit some code for the main page and admin page to work, like the CASHsystem.php. I also needed to delete the .htaccess file for it to show up. I don't think this is necessary so I assume I am doing something wrong, that leads to all these problems.
    My root htdocs folder is as follows:
    Admin(folder)

    Framework(folder) --> tried moving out of the www directory and it works, this is because it's more simple.

    Interfaces(folder) --> also contains the same admin folder as the root.

    That means that I need to visit http://localhost/interfaces/ for the site to show up.

    What am I doing wrong?

  5. invibious closed this discussion on 17 Nov, 2015 03:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac