Can't intall / can't mkdir

DJM's Avatar

DJM

08 Aug, 2012 02:32 PM

Hi guys.
Been following your work for quite some time (e.g. using the tweet2track) and finally decided to test the DIY framework.
I tested it in a subdirectory on 1 of my sites, that already runs WordPress (latest version - self hosted).

File DL: OK
asks for directory, email and PW: OK
=> can't create directory, stops @ line 527 / permission denied

if (!mkdir($user_settings['frameworklocation'],0755,true))

Checked permissions (755), Safe_mode is off, Curl is there... created the directory myself... with no effect.
Tried with full 777, just to be sure, but the installer is not allowed to run anymore (error 500)...

Any other idea what could be the cause?
I know my host can be really very restrictive on what's allowed or not... But need to figure out what could be wrong...

PS: have multiple sites running WP or CMS Made Simple or PrestaShop already on same platform:
PHP Version 5.3.3-7+squeeze13
This server is protected with the Suhosin Patch 0.9.9.1

cURL support enabled
cURL Information 7.21.0

Sincerely
DJM

  1. 1 Posted by mb on 09 Sep, 2012 01:22 AM

    mb's Avatar

    Hi there...

    Having the same problem:

    • Installing locally on Mac OS 10.5.8
    • Got php up and running
    • Created "cashmusic" subfolder off of 'webroot'
    • Did the chmod 777 thing and re-ran install
    • Got the Oh. Shit. message as well

    I'm sure it's something really simple, just don't see it. Really want to check this out. Please help :)

    Best
    mb

  2. 2 Posted by mb on 09 Sep, 2012 01:23 AM

    mb's Avatar

    Oh duh. Here's the message:

    Notice: Undefined variable: user_settings in /Library/WebServer/Documents/cashmusic/cashmusic_web_installer.php on line 522

    Warning: mkdir() [function.mkdir]: Permission denied in /Library/WebServer/Documents/cashmusic/cashmusic_web_installer.php on line 527
    Oh. Shit. Something's wrong.
    Couldn't create a directory at/Library/WebServer/cashmusic.

  3. 3 Posted by Wizard Eibon on 03 Feb, 2013 03:37 PM

    Wizard Eibon's Avatar

    Same here....OP in August '12 and still no answer?! C'mon Cashmusic!

  4. Support Staff 4 Posted by Jesse von Doom on 04 Feb, 2013 06:03 AM

    Jesse von Doom's Avatar

    I'm sorry...without knowing the exact environment I really don't have an answer for you. If you're installing locally you should be using the command-line dev installer, not the web installer — as specified in both our README as well as our wiki:

    https://github.com/cashmusic/platform/blob/master/README.md
    https://github.com/cashmusic/platform/wiki/Installing-the-platform

  5. Jesse von Doom closed this discussion on 04 Feb, 2013 06:03 AM.

  6. mb re-opened this discussion on 04 Feb, 2013 09:31 PM

  7. 5 Posted by mb on 04 Feb, 2013 09:31 PM

    mb's Avatar

    thanks :)

    I'm working with the online beta version now, so it's not a problem. But thanks
    for the reply :)

    m

  8. 6 Posted by DJM on 04 Feb, 2013 09:47 PM

    DJM's Avatar

    Same for me, I moved to the hosted beta platform.
    Sincerely
    DJM

  9. Support Staff 7 Posted by Jesse von Doom on 04 Feb, 2013 09:53 PM

    Jesse von Doom's Avatar

    Good to know. Just as an FYI, they are the same codebase, we just haven't gone through the process of releasing an updater for the downloadable/single-user version yet. Probably going to wait until after a month or two of testing the hosted because there are some pretty major upgrades planned, especially to UX.

    I'm the primary developer and do 95+% of the coding — so the installer/updater doesn't get nearly enough love. Hopefully as it's getting easier for people to participate we'll be able to make that process smoother for all — I'd love the update to be basically as easy as setting up a new hosted account.

  10. 8 Posted by mb on 04 Feb, 2013 10:04 PM

    mb's Avatar

    no problem. Jesse, I appreciate all of the work you've put into this :)

  11. Jesse von Doom closed this discussion on 05 Feb, 2013 08:58 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac